const regex = new RegExp('<a[^>]+href="(.*?)"', '')
const str = `<h2>Пример использования</h2><a href="http://test.me/please">Ссылка1</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}