package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a[^>]+href="(.*?)"`)
var str = `<h2>Пример использования</h2><a href="http://test.me/please">Ссылка1</a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}