re = /<a[^>]+href="(.*?)"/
str = '<h2>Пример использования</h2><a href="http://test.me/please">Ссылка1</a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end