using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"заработная плата";
string input = @"фувамс заработная плата йфцуафу
фувамс заработная плата йфцуафу
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}