const regex = new RegExp('заработная плата', '')
const str = `фувамс заработная плата йфцуафу
фувамс заработная плата йфцуафу
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}