using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?-i)((?:[A-Z][a-z]* ??)*?)\s*users";
string input = @"to Apple Tablet users or anything for Apple Tablet users";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}