re = /(?-i)((?:[A-Z][a-z]* ??)*?)\s*users/
str = 'to Apple Tablet users or anything for Apple Tablet users'
# Print the match result
str.match(re) do |match|
puts match.to_s
end