const regex = /(?-i)((?:[A-Z][a-z]* ??)*?)\s*users/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?-i)((?:[A-Z][a-z]* ??)*?)\\s*users', '')
const str = `to Apple Tablet users or anything for Apple Tablet users`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}