package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?-i)((?:[A-Z][a-z]* ??)*?)\s*users`)
var str = `to Apple Tablet users or anything for Apple Tablet users`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}