$re = '/(?-i)((?:[A-Z][a-z]* ??)*?)\s*users/';
$str = 'to Apple Tablet users or anything for Apple Tablet users';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);