using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/(.*?)\.website\.com\/.*?&type=(.*?)&.*?";
string input = @"http://123.website.com/?&guid=blahblahblah&page=something&type=abc&adv=abc1234&site={siteID}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}