$re = '/https?:\/\/(.*?)\.website\.com\/.*?&type=(.*?)&.*?/';
$str = 'http://123.website.com/?&guid=blahblahblah&page=something&type=abc&adv=abc1234&site={siteID}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);