package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/(.*?)\.website\.com\/.*?&type=(.*?)&.*?`)
var str = `http://123.website.com/?&guid=blahblahblah&page=something&type=abc&adv=abc1234&site={siteID}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}