re = /https?:\/\/(.*?)\.website\.com\/.*?&type=(.*?)&.*?/
str = 'http://123.website.com/?&guid=blahblahblah&page=something&type=abc&adv=abc1234&site={siteID}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end