// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https?:\/\/(.*?)\.website\.com\/.*?&type=(.*?)&.*?").unwrap();
let string = "http://123.website.com/?&guid=blahblahblah&page=something&type=abc&adv=abc1234&site={siteID}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}