#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([a-z]+\s)([0-9]+\s)([A-Z]+)"
Local $sString = "aaa 111 AAA bbb 222 BBB ccc 333 CCC ddd 444 DDD"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)