$re = '/([a-z]+\s)([0-9]+\s)([A-Z]+)/m';
$str = 'aaa 111 AAA bbb 222 BBB ccc 333 CCC ddd 444 DDD';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;