const regex = /([a-z]+\s)([0-9]+\s)([A-Z]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z]+\\s)([0-9]+\\s)([A-Z]+)', 'gm')
const str = `aaa 111 AAA bbb 222 BBB ccc 333 CCC ddd 444 DDD`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);