package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z]+\s)([0-9]+\s)([A-Z]+)`)
var str = `aaa 111 AAA bbb 222 BBB ccc 333 CCC ddd 444 DDD`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}