import Foundation
let pattern = #"([a-z]+\s)([0-9]+\s)([A-Z]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"aaa 111 AAA bbb 222 BBB ccc 333 CCC ddd 444 DDD"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)