using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|^pub-\d{5}(?=\d*$))\K\d(?=\d{5})";
string substitution = @"*";
string input = @"pub-1885335825402893";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}