use strict;
my $str = 'pub-1885335825402893';
my $regex = qr/(?:\G(?!^)|^pub-\d{5}(?=\d*$))\K\d(?=\d{5})/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";