const regex = /(?:\G(?!^)|^pub-\d{5}(?=\d*$))\K\d(?=\d{5})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|^pub-\\d{5}(?=\\d*$))\\K\\d(?=\\d{5})', 'gm')
const str = `pub-1885335825402893`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);