$re = '/(?:\G(?!^)|^pub-\d{5}(?=\d*$))\K\d(?=\d{5})/m';
$str = 'pub-1885335825402893';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;