const regex = /\[\]([a-z]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\]([a-z]+)', '')
const str = `2015-07-06 14:44:51 194.56.211.10 []created /home/ftp/users/grafik/projektWiosna/index.phtml 226 grafik 739
Sun Aug 27 16:28:20 2006 [pid 13962] [xx] OK UPLOAD: Client "1.2.3.4", "/a.php", 8338 bytes, 18.77Kbyte/sec`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}