// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\]([a-z]+)").unwrap();
let string = "2015-07-06 14:44:51 194.56.211.10 []created /home/ftp/users/grafik/projektWiosna/index.phtml 226 grafik 739
Sun Aug 27 16:28:20 2006 [pid 13962] [xx] OK UPLOAD: Client \"1.2.3.4\", \"/a.php\", 8338 bytes, 18.77Kbyte/sec";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}