import re
regex = re.compile(r"\[\]([a-z]+)")
test_str = ("2015-07-06 14:44:51 194.56.211.10 []created /home/ftp/users/grafik/projektWiosna/index.phtml 226 grafik 739\n"
"Sun Aug 27 16:28:20 2006 [pid 13962] [xx] OK UPLOAD: Client \"1.2.3.4\", \"/a.php\", 8338 bytes, 18.77Kbyte/sec")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")