package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<key>[^=;\r\n]+)=(?<value>"[^"]*"|[^;\n\r]*);?(?<comment>.*)`)
var str = `This="isnot;acomment"
This="isa";comment
This="isa;special";case
This=isasimplecase
This=isasimple;comment
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}