$re = '/^(?<key>[^=;\r\n]+)=(?<value>"[^"]*"|[^;\n\r]*);?(?<comment>.*)/m';
$str = 'This="isnot;acomment"
This="isa";comment
This="isa;special";case
This=isasimplecase
This=isasimple;comment
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);