import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<key>[^=;\\r\\n]+)=(?<value>\"[^\"]*\"|[^;\\n\\r]*);?(?<comment>.*)";
final String string = "This=\"isnot;acomment\"\n"
+ "This=\"isa\";comment\n"
+ "This=\"isa;special\";case\n"
+ "This=isasimplecase\n"
+ "This=isasimple;comment\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}