const regex = /^(?<key>[^=;\r\n]+)=(?<value>"[^"]*"|[^;\n\r]*);?(?<comment>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<key>[^=;\\r\\n]+)=(?<value>"[^"]*"|[^;\\n\\r]*);?(?<comment>.*)', 'gm')
const str = `This="isnot;acomment"
This="isa";comment
This="isa;special";case
This=isasimplecase
This=isasimple;comment
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}