#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(:\s*[)p(])(*SKIP)(*FAIL)|[^a-z0-9 ]"
Local $sString = ": ) instead of :)" & @CRLF & _
"" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
": P instead of :P" & @CRLF & _
"" & @CRLF & _
"Hi! Glad # to _ see : you :)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")