using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(:\s*[)p(])(*SKIP)(*FAIL)|[^a-z0-9 ]";
string input = @": ) instead of :)
or
: P instead of :P
Hi! Glad # to _ see : you :)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}