re = /(?i)(:\s*[)p(])(*SKIP)(*FAIL)|[^a-z0-9 ]/
str = ': ) instead of :)
or
: P instead of :P
Hi! Glad # to _ see : you :)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end