$re = '/(?i)(:\s*[)p(])(*SKIP)(*FAIL)|[^a-z0-9 ]/';
$str = ': ) instead of :)
or
: P instead of :P
Hi! Glad # to _ see : you :)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);