package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(:\s*[)p(])(*SKIP)(*FAIL)|[^a-z0-9 ]`)
var str = `: ) instead of :)
or
: P instead of :P
Hi! Glad # to _ see : you :)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}