#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\(?\d{3}\)?[- ]\d{3}-\d{4}"
Local $sString = "888-555-4444" & @CRLF & _
"My phone number is (871) 518-1912 okay?" & @CRLF & _
"This thing is kuhl and my phone number is 67-19191-191" & @CRLF & _
"What was my number? Oh, it's 6710910919" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")