using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(?\d{3}\)?[- ]\d{3}-\d{4}";
string input = @"888-555-4444
My phone number is (871) 518-1912 okay?
This thing is kuhl and my phone number is 67-19191-191
What was my number? Oh, it's 6710910919
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}