package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<xref>[^\d]+)(\d)(<\/xref)`)
var str = `This is a example string and first line with <xref>id1</xref>then,<xref>id2</xref>and with no line breaks<xref>id3</xref>. This is a second line which has <xref>id4</xref>`
var substitution = "$1eqvalue$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}