use strict;
my $str = 'This is a example string and first line with <xref>id1</xref>then,<xref>id2</xref>and with no line breaks<xref>id3</xref>. This is a second line which has <xref>id4</xref>';
my $regex = qr/(<xref>[^\d]+)(\d)(<\/xref)/mp;
my $subst = '$1eqvalue$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";