$re = '/(<xref>[^\d]+)(\d)(<\/xref)/m';
$str = 'This is a example string and first line with <xref>id1</xref>then,<xref>id2</xref>and with no line breaks<xref>id3</xref>. This is a second line which has <xref>id4</xref>';
$subst = "$1eqvalue$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;