const regex = /(<xref>[^\d]+)(\d)(<\/xref)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<xref>[^\\d]+)(\\d)(<\\\/xref)', 'gm')
const str = `This is a example string and first line with <xref>id1</xref>then,<xref>id2</xref>and with no line breaks<xref>id3</xref>. This is a second line which has <xref>id4</xref>`;
const subst = `$1eqvalue$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);