#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?=bach|wänt|wäns|prägs|prägt|quäls|quält|Rätsel|Rätsele|Rätselen|souveränst|souveränste|souveränstem|souveränsten|souveränster|souveränt|trägst|trägste|trägstem|trägsten|trägster|trägt|zäms|zämt)((\S*?[aä])|፼)([b-df-hj-np-tv-z][b-df-hj-np-tv-z]\S*)(?!\S*(?<=(aprägs|obacht)\S*))"
Local $sString = "Match: bach prägs " & @CRLF & _
"" & @CRLF & _
"Don’t match: beobacht beobachten aprägs" & @CRLF & _
"" & @CRLF & _
"obachtbach" & @CRLF & _
"" & @CRLF & _
"bprags"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")