use strict;
my $str = 'Match: bach prägs
Don’t match: beobacht beobachten aprägs
obachtbach
bprags';
my $regex = qr/(?=bach|wänt|wäns|prägs|prägt|quäls|quält|Rätsel|Rätsele|Rätselen|souveränst|souveränste|souveränstem|souveränsten|souveränster|souveränt|trägst|trägste|trägstem|trägsten|trägster|trägt|zäms|zämt)((\S*?[aä])|፼)([b-df-hj-np-tv-z][b-df-hj-np-tv-z]\S*)(?!\S*(?<=(aprägs|obacht)\S*))/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}