const regex = new RegExp('(?=bach|wänt|wäns|prägs|prägt|quäls|quält|Rätsel|Rätsele|Rätselen|souveränst|souveränste|souveränstem|souveränsten|souveränster|souveränt|trägst|trägste|trägstem|trägsten|trägster|trägt|zäms|zämt)((\\S*?[aä])|፼)([b-df-hj-np-tv-z][b-df-hj-np-tv-z]\\S*)(?!\\S*(?<=(aprägs|obacht)\\S*))', 'gmi')
const str = `Match: bach prägs
Don’t match: beobacht beobachten aprägs
obachtbach
bprags`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}