re = /(?=bach|wänt|wäns|prägs|prägt|quäls|quält|Rätsel|Rätsele|Rätselen|souveränst|souveränste|souveränstem|souveränsten|souveränster|souveränt|trägst|trägste|trägstem|trägsten|trägster|trägt|zäms|zämt)((\S*?[aä])|፼)([b-df-hj-np-tv-z][b-df-hj-np-tv-z]\S*)(?!\S*(?<=(aprägs|obacht)\S*))/mi
str = 'Match: bach prägs
Don’t match: beobacht beobachten aprägs
obachtbach
bprags'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end