import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=bach|wänt|wäns|prägs|prägt|quäls|quält|Rätsel|Rätsele|Rätselen|souveränst|souveränste|souveränstem|souveränsten|souveränster|souveränt|trägst|trägste|trägstem|trägsten|trägster|trägt|zäms|zämt)((\\S*?[aä])|፼)([b-df-hj-np-tv-z][b-df-hj-np-tv-z]\\S*)(?!\\S*(?<=(aprägs|obacht)\\S*))";
final String string = "Match: bach prägs \n\n"
+ "Don’t match: beobacht beobachten aprägs\n\n"
+ "obachtbach\n\n"
+ "bprags";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}