using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d+)\s*[Ss][Ff]\b";
string input = @"'other stuff 1000 SF'
'other stuff 1000SF'
a b c 5sf 10sf 12sf
aa 00 1100 fs sf 1sf
1sf.
.1sf?
5sff";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}