import Foundation
let pattern = #"\b(\d+)\s*[Ss][Ff]\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
'other stuff 1000 SF'
'other stuff 1000SF'
a b c 5sf 10sf 12sf
aa 00 1100 fs sf 1sf
1sf.
.1sf?
5sff
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)