$re = '/\b(\d+)\s*[Ss][Ff]\b/';
$str = '\'other stuff 1000 SF\'
\'other stuff 1000SF\'
a b c 5sf 10sf 12sf
aa 00 1100 fs sf 1sf
1sf.
.1sf?
5sff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);